Temp Tables not working with Grid 8.2 and PDO connection

Discuss everything related to ApPHP DataGrid class. All versions. Any questions related to the ApPHP DataGrid developing or using should be posted to this forum.
Please, check out Knowledge Base first before you post a question.

Moderator: alexandrleonenko

Forum rules
Posts are to be made in the relevant forum. Users are asked to read the forum descriptions before posting.
Buzz Brown
Senior
Senior
Posts: 41
Joined: Apr 18th, '10, 09:47
Location: Auburn Hills, MI

Temp Tables not working with Grid 8.2 and PDO connection

Postby Buzz Brown » Jan 5th, '18, 20:09

We have been using ApPHP for several years. Many of our PHP pages use MySQL Temp Tables rather than physical tables. We noticed we had not updated ApPHP for some time and recently started testing 8.2. We discovered that the tool does not work with temp tables and a PDO connection. We are not sure which version broke the ability to use temp tables but know it does not work with 8.2. Any help would be appreciated.

administrator
Site Admin
Site Admin
Posts: 6001
Joined: Jan 7th, '09, 23:18
Contact:

Re: Temp Tables not working with Grid 8.2 and PDO connection

Postby administrator » Jan 7th, '18, 10:02

Did you define PDO connection as required?
viewtopic.php?f=33&t=1519

Buzz Brown
Senior
Senior
Posts: 41
Joined: Apr 18th, '10, 09:47
Location: Auburn Hills, MI

Re: Temp Tables not working with Grid 8.2 and PDO connection

Postby Buzz Brown » Jan 11th, '18, 19:07

Yes, we are defining the PDO connection. It seems the page is trying to handle two PDO connections. One that we initialize and one that the tool initializes. Is it possible to send our outside connection into the grid tool?


Return to “ApPHP DataGrid”